Wednesday, September 17, 2008

iTunes 8

A couple of people have noted problems with iTunes 8. In the little testing I have done I am yet to run into any problems. If you have any issues please add a comment here or email me

jrmwillis@hotmail.com

15 comments:

kaoz70 said...

Hi, I just installed MusicBridge 2.0.1, and every time I try to do something I get this error:

You pressed stop or there was an error

Error006: Unable to cast COM object of type 'iTunesLib.iTunesAppClass' to interface type 'iTunesLib.IiTunes'. This operation failed because the QueryInterface call on the COM component for the interface with IID '{9DD6680B-3EDC-40DB-A771-E6FE4832E34A}' failed due to the following error: No such interface supported (Exception from HRESULT: 0x80004002 (E_NOINTERFACE)).

Any ideas?

Im running Vista x64 SP1, iTunes 8.0.0.35

Ohh and btw, great program!!

* said...

Hmm, it could be an x64 issue, can't say I have ever had my hands on it to test there...

Has it ever run on x64 for you?

The error is pretty specific, but I don't know why it would specifically fail for you.

I guess it is possible that there is a difference in an iTunes 7 to 8 upgrade compared to a fresh iTunes 8 install.

It's really hard for me to say without being able to reproduce it...

kaoz70 said...

Well, its actually the first time Ive installed it (Just bought an iPhone). Tomorrow Ill try and see if it works on a Vista x86 laptop and nother XP x86 Computer I have around, both with iTunes 8, and post the results

James said...

That would be really useful to know.

As noted in the readme, I do strongly suggest you have a good backup of your music library before running MusicBridge (I would hope you do anyway).

kaoz70 said...

haha, yeah, well tomorrow Ill take advantage of this situation and make a backup of all my music, thanks for reminding me.

CRW said...

Music bridge was working great until I got iTunes 8. Now It just crashes when I try to sync playlists from WMP. I've re-installed Music bridge, but It still just crashes.

Here's the report:

EventType : clr20r3 P1 : musicbridge.exe P2 : 1.0.2815.27606
P3 : 46ed9f34 P4 : musicbridge P5 : 1.0.2815.27606 P6 : 46ed9f34
P7 : ac P8 : 7 P9 : pszqoadhx1u5zahbhohghldgiy4qixhx

James said...

I ran a playlist sync in both directions. The WMP to iTunes took a long time to report back but did complete without error.

Anyone else here reproduce the error?

Somebody was having a different error since installing iTunes 8, they reinstalled iTunes 8 and it fixed it for them.

Shippy said...

I just upgraded to iTunes 8 and then I removed all songs out of my WMP library so I could get a fresh start. I sync'd from iTunes to WMP and MusicBridge acts as if everything was successful, but I open up WMP and nothing shows up in my library. If I try to sync my playlists, it fails because it could not find the song info in WMP. Is this some sort of caching issue? I'm running on x86 Vista SP1.

Thanks!

CRW said...

Okay my problem was fixed when I re installed iTunes 8, thanks James.

James said...

Shippy,

You need WMP to pick-up all of your songs back into your library BEFORE running MusicBridge.

James said...

It seems based on feedback that I am getting that MusicBridge works with iTunes 8. A number of people have encountered errors but reinstalling iTunes 8 seems to fix it.

kaoz70 said...

Man... I haven't had time to check in my other PCs, sorry for that.

Ill try reinstalling iTunes (sometime soon) I hope that will fix the problem

Hawkeyestud89 said...

I downloaded itunes 8 and now everytime i try opening my itunes i get this error saying that An unhandled win32 exception has occured in iTunes.exe[4884]. Just-In-Time debugging this exception failed with the following error: No installed debugger has Just-In-Time debugging enabled in Visual Studio Just-In-Time debugging can be enabled from Tools/Options/Debugging/Just-In-Time. I have no idea what this is and i was hoping u could help me out???

Daniel said...

Hi,
I try to sync from Itunes 8 to wmp11/vista32bitsp1
Before I cleaned up the dir C:\Users\XYZ\AppData\Local\Microsoft\Media Player. After that started
MusicBridge 2.0.1 and sync General Data, finished with success: CurrentDatabase_360.wmdb about 1MB size. I started wmp an no files are shown in my library. Whats my mistake? My music files are on drive e: Thanks for any help :)

Heidi said...

Hi - I have a problem or maybe a bug. When syncing iTunes general data to WMP it copies iTunes' "Artist" into WMP's "Album Artist" rather than "Contributing Artist". This presents a problem when just say the album artist is Usher but the (contributing)artists are Usher and T.I. This then renames folders of artists and makes filepaths go wrong in iTunes and you have to relocate every single song.

I also have a problem contacting you on your email. My emails bounce back.